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The Pintar VirtuaLab TM Mechanics module has certain
features that are different from any other Pintar
VirtuaLab TM modules.

l If you are new to Pintar VirtuaLab TM you might want
to familiarize yourself with the components which
are found in the interface.

l Next, the fastest way of using the Pintar VirtuaLab TM

is by doing an experiment. This manual will give
you step-by-step instructions on conducting
an experiment.

This chapter covers the following sections;

Section Title See page

A Components of the Interface

B The Experiment

Chapter Four
Mechanics

Introduction

In this chapter

Overview
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Section A
Components of the Interface

Overview

In order, to use the Pintar VirtuaLab TM, you need to be
familiar with the different components that you will be
using in conducting your experiment.

This section covers the following topics;

Topic See page

The Work Window

The Types of Menus

The Object Bar

The Control Panel

Introduction

In this section
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The Work Window is

l A simulation of the real lab, so, you can create
and conduct your experiments freely.

l The space where your electrical components
are connected together to create an experiment.

Introduction

The Work Window
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It contains:

l Starting new experiment

l Opening a previously saved
experiment

l Closing the active experiment
l Saving an experiment
l Saving a new experiment
l Reverting an experiment to its most

recently saved state
l Running/playing your project
l When an experiment is running,

choosing ‘Run/Pause’ command will
pause the experiment

l Stopping to editing your experiment
l This is exactly equivalent to clicking

on the ‘Reset’ button at the bottom
of the Work Window

l Printing projects
l Setting preferences
l Ending work session

It contains:

l Undoing last action
l Editing an experiment
l Cut
l Copy
l Paste
l Deleting one, more or all

components from the Work Window
l Selecting all components on the

Work Window
l The ‘Push Back’ command pushes

the selected object back in order to
see the objects behind it.

The File menu

The Types of Menus

The Edit menu
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It contains:

l The Zoom-In tool magnifies the Work
Window by a factor of two. This is exactly
equivalent to clicking on the ‘Zoom In’
button at the bottom of the Work
Window

l The Zoom-Out tool decreases the
magnification of the Work Window by
half

l This command presents a View Size
dialog to set these parameters about
view

l The Snap Move feature, when selected,
causes an object to snap to predefined
grid positions.
When this feature is in effect, a check
appears before the command

l This toggle hides and shows the rulers
l This toggle hides and shows x, y axes in

your Work Window
l This toggle hides and shows the Object

Bar in the left side
l This toggle hides and shows the Status

Bar
l Tracking

l Tracking Off
Turn off trace of the experiment
in the Work Window

l Tracking Every 1, 2, 4, 8, 16, 32,
Frames
Turn on trace of the experiment
in the Work Window at different
tracking rate. More frames
means longer time interval.

l Others
This command opens a
Tracking Frame dialog to let you
choose your own desired
tracking rate.

l The ‘Time Step’ command opens a Time
Step dialog to let you set the time step
and accuracy in running experiments.

The View menu

The Types of Menus
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The World Menu

The Measure
Menu

The Types of Menus

It contains:

l The ‘Gravity’ command opens a
Gravity dialog to set the gravita-
tional forces.

The gravitational forces can be turn
on or off by selecting between the
three modes,
l None,
l Vertical, and
l Planetary
Options in the Gravity Dialog

l The ‘Air Resistance’ command
opens the ‘Air Resistance’ dialog to
set the forces caused by air
resistance

l When this option in the World menu
is selected, the collision detection
feature is turned off. Objects that
are collision bound simply slide over
each other

Turning off collision detection
speeds up an experiment when no
collision is expected in the experi-
menting

l When this option in the World menu
is selected, objects do not rotate,
even when a torque is applied to
the object

Turning off rotation speeds up an
experiment when rotation is not
monitored in the experiment

It contains the functions for measuring
your experiment
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The Vector
Menu

The Window
Menu

The Types of Menus

Show one or more Vector(s) from the
Vector menu, a check is shown for the
selected vector. The vectors in Vector
menu are dim until you select an object
by clicking it in the Work Window.

The Window menu offers the following
commands for arranging multiple views
of multiple documents in the application
window :

l This command arranges multiple
open windows in an overlapped
fashion

l This command arranges multiple
open windows as non-overlapping
tiles

l This command arranges the icons of
minimized windows at the bottom of
the main window

l Pintar VirtuaLab Waves displays a list
of currently open document
windows in the Window menu.
Choose a document from this list to
make its window active
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It contains:

l The Help system is easy-to-under-
stand and provides assistance to
using the Pintar VirtuaLab Optics.
The Help system opens in a separate
window; and can be kept open,
while you work on your experiment.

Note:
The Pintar VirtuaLab Optics is also
equipped with ‘context-sensitive’
Help.

l This option opens a panel, which
contains information regarding
your copy of Pintar VirtuaLab Optics

The Help Menu

The Types of Menus
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Introduction

The Object Bar

The Object Bar holds the tools for
creating and manipulating objects.

The tools are as follows:

Selection Tool    l

Rectangle    l

Polygon    l

Gear (Belt)    l

Spring    l

Rods    l

Pulleys    l

Hinge Joint    l

Circle Slot    l

Force    l

Motor    l

Magnetic Field    l

l Circle

l Gear

l Gear (Belt)

l Ropes

l Damper

l Pin Joint

l Slot Joint

l Curvilinear Slot

l Linear Motor

l Electrostatic Field

l Text Tool
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The Control Panel consists of the

l Zooms in (or Play),
l Resets
l Pauses
l Runs and
l Steps

What is the
Control Panel

The Control Panel

Function

The Zoom-In tool magnifies the Work
Window by a factor of two. The new
view area is centered on the area
around the pointer.

The Zoom-Out tool decreases the
magnification of the Work Window by
half.

Click on the Reset button resets the
experiment to its original edit mode.

Click on this button to ‘pause’ the
experiment. When an experiment is
pausing, the objects cannot be
edited. Click on ‘run’ button to
continue this experiment.

Click on this button to ‘run’ the
experiment. When an experiment is
running, the objects cannot be
edited. Click on ‘pause’ button to
pause the experiment

A single click on this button moves
the experiment forward by one step.
In tracking mode one step is deter-
mined by the ‘Tracking’ setting in the
World menu
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Button

Zoom In

Zoom Out

Reset

Pause

Run

Step



Pintar VirtuaLab Mechanics is a powerful simulation
laboratory for Newtonian mechanics on your desktop!

Through a user-friendly Work Window, you create
experiments by assembling and altering the properties
of each virtual object as you progress.

Experiments come to life with stunning accuracy and
results are immediate.

This section covers the following topics;

Topic See page

Background

Experiment set-up

Observation

Troubleshooting

Section B
The Experiment

Introduction

section

Overview
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In this tutorial, the goal is to put together a simple
experiment that would verify Hooke’s Law.

To discover the relationship between applied force and
extension of an elastic material

For this experiment, you would need the following
components:
l A spring and

l A circular mass object

Experiment
goal

Objective

Components

Background

Pintar VirtuaLab TM Manual    l    Pintar VirtuaLab TM  MECHANICS



Follow these steps to start designing your experimentDesigning the
experiment

Experiment Set-Up

Step Action

1 To start a new project, select ‘New’ from the
File menu

2 To draw (place) a mass object on the
VirtuaLab,
l Select the circle tool in the Toolbox.

l Move the cursor to the VirtuaLab,

l click and drag in a downward diagonal
direction.

3 To move an object, click on the object and
drag it towards the left side of the VirtuaLab

4 To set the parameters of the circle mass
object, double-click on the circle mass.

Note:
A properties dialog panel for the circle will
appear. You should be in the ‘Attributes’ group
of parameters as indicated by the tab above
the parameter settings.
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Experiment Set-Up

Step Action

5 Set the parameter to:

l For the Position parameters, set ‘X’ to 1,
and ‘Y’ to 3.

l Click on the ‘Materials’ tab. Set the
‘Mass’ to 1 kg

l Click on the ‘Vectors’ tab. In the scrolling
list, select ‘Gravitational Force’ and click
the ‘Show magnitude’ checkbox

6 To take a spring, select the spring tool in the
Toolbox

Adjust the endpoints of the spring so that they
are aligned in a vertical straight line with the
center of the circle mass.

l Click and drag on the endpoints to align
them.

7 To connect one endpoint of the spring to the
circle mass and fix the other endpoint to the
VirtuaLab.

Note:
You do not have to explicitly ‘fix’ an endpoint
of a constraint to the VirtuaLab. Any endpoint
that is on the VirtuaLab is considered fixed to it.
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Experiment Set-Up

Step Action

8 Click on the circle mass and drag upwards to
the VirtuaLab such that the spring looks about
two inches (five centimeters) long.

9 To set appropriate parameters for the spring,
double-click on the spring to open its
properties dialog panel.

10 Set the spring constant to 10 N/m.

Note:
Check that the rest length and current length
have the same values. If the values are
different, the spring is in either compression or
extension

11 To annotate or label your experiment,
l select the Text tool in the Toolbox and

place it to the desired location

l Double-click on the text object, and the
text properties dialog panel appears.
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Experiment Set-Up

Step Action

12 To save your experiment, select ‘Save As.....’
from the file menu

Note: If you are using a free trial version of
Pintar VirtuaLabTM Mechanics, you will not
be able to save your experiment
because this feature has been disabled
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Running your
experiment

Step Action

1 To run your experiment, click on the ‘Run’
button in the Control Panel

2 To stop your experiment, click on the ‘Stop’ or
‘Construct’ button in the Control Panel.

3 To add air resistance,

l Select ‘Air Resistance…’ from the World
menu.

l Set the air resistance to 2/s

4 To run your experiment again, click on the Step
button, not the Run button. The mass object
moves just slightly

5 To take readings for record, note down the
‘y’ value. This is the initial position of the mass

Follow these steps to run your experiment



Experiment Set-Up

Step Action

6 Click on the Run button and wait for the
oscillating mass to stop

7 Records its ‘y’ value again   8Subtract the first
reading from the second reading, and the
difference is the extension of the spring
caused by the mass object

8 Subtract the first reading from the second
reading, and the difference is the extension of

the spring caused by the mass object
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To edit your
experiment

Step Action

1 Stop the current experiment and repeat steps
4 to 10 of the experiment set-up

2 Change the mass of the circle object to 1.5kg

3 Click on the ‘Run’ button again

4 Do this a few more times, each time increasing
the mass of the circle object by 0.5kg

5 To use magnification, click once on the
magnifying glass with a minus sign in the
Control Panel.

Note:
You’ll see that the VirtuaLab has been scaled
down to give you more VirtuaLab room to
work with

6 To end your work session, select ‘Quit’ from the
File menu

Follow these steps to edit your experiment
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With the data collected, tabulate as shown below

Plot a graph of extension (y-axis) against force (x-axis).
The diagram below shows what the graph may look like.

Findings

Plot the graph

Observation
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In the unlikely event, you encounter a problem with
Pintar VirtuaLabTM, it may be helpful to see what are the
common problems faced by users and the correspond-
ing causes and suggested solutions.

Note:
In the event the problem that you are facing is not listed
here, we will be happy to hear from you. Contact :

Customer Service Department:
info@pintarmedia.com
Technical Support Department:
help@pintarmedia.com

I cannot run Pintar VirtuaLab Mechanics

Introduction

Problem

Troubleshooting

Possible causes Possible solutions

Reload the Pintar
VirtuaLab Mechanics
program file from the
original program disk

Pintar VirtuaLab Me-
chanics will not run on
Windows 3.1 or Windows
for workgroup 3.11,
because this product is
a full 32-bits program
which runs only on 32-bits
operating system like
Windows 95 or Windows
NT.

The Pintar VirtuaLab
Mechanics program file
is damaged

The operating system in
your PC computer is not
Windows 95 or Windows
NT.
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Problem

Problem

Problem

Troubleshooting

Possible causes Possible solutions

Decrease the time step
of each frame. Select
‘Time Step…’ from View
menu to set the time

step

The time step of each
frame is too large

Possible causes Possible solutions

Increase the time step of
each frame. Select ‘Time
Step…’ from View menu
to set the time step and
accuracy

Upgrade your PC to a
faster one. Sorry!

The time step of each
frame is too small, or the
accuracy of calculations
is too high

Your PC is too slow

The simulation is slow

The simulation is too fast

Something seems wrong during simulation

Possible causes Possible solutions

Mass objects MUST NOT
OVERLAP each other,
except when they are
connected by a pin
joint. The result of
simulation may be
unpredictable if mass
objects overlap. Move
these overlapping mass
objects aside so that
they no longer do so

Mass objects
overlapping
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Possible causes Possible solutions

Increase the accuracy
in simulating this experi-
ment. Select ‘Time
Step…’ from View menu
to set the accuracy to
‘Extremely Accurate’. If
you want to get more
accuracy, simply
increase the slices of
each time step. But, it
means that more time
would be needed to
calculate each frame.

The accuracy of
calculation is too low to
solve this experiment.

Problem The Image On The Monitor Looks Scrambled.

Possible causes Possible solutions

Ensure that the refresh
rate for video and
monitor are the same

Your video card is
incompatible with your
monitor


